Workspace ONE UEM: Workspace One UEM - Performance issues / Germany (Partial Region)

Incident Report for Omnissa Workspace ONE

Resolved

The issue is now resolved. We apologize for the inconvenience and thank you for your patience and continued support. Operations teams will continue to monitor system performance levels and investigate the root cause of the issue.

System reliability is a top priority at Omnissa Workspace ONE, and we are making continuous improvements to better our systems.
Posted Apr 22, 2026 - 17:55 UTC

Update

Omnissa Workspace ONE has noted all underlying issues have been resolved and missing data is continuing to be made available.

Operations teams continue to actively work towards complete recovery.
Posted Apr 22, 2026 - 17:39 UTC

Update

Omnissa Workspace ONE has noted partial recovery with SaaS environments and continues to work towards complete rcovery.

Operations teams continue to actively work towards complete recovery.
Posted Apr 22, 2026 - 16:16 UTC

Update

Omnissa Workspace ONE has noted partial recovery with some missing data being made available on the affected pages. Omnissa teams will continue working to have all data made available.

Operations teams continue to actively work towards complete recovery.
Posted Apr 22, 2026 - 15:31 UTC

Identified

Omnissa Workspace ONE is investigating reports of performance issues with SaaS environments.

Operations teams have identified the issue is impacting data loading on these pages:
-Device list
-Application list
-Event log
-Deployment tracking

The issue has been identified and a resolution is actively being implemented.

Omnissa Cloud Services portal has been updated for customers affected by this event.

Please check the Omnissa Cloud Services portal to confirm if your environment is affected by this event.

System reliability is a top priority at Omnissa Workspace ONE, and we are making continuous improvements to better our systems.
Posted Apr 22, 2026 - 14:43 UTC
This incident affected: Workspace ONE UEM (Workspace ONE UEM - Germany).