The Infrastructure Maintenance for Horizon Cloud Service Next-Gen is now complete.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Posted Jun 08, 2025 - 05:49 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 08, 2025 - 02:30 UTC
Scheduled
Horizon Cloud Service Next-Gen is going to perform an Infrastructure Maintenance in Europe region during the below maintenance window.
Maintenance Window: • Start: Sunday, June 08, 2025, 02:30 UTC • End: Sunday, June 08, 2025, 06:30 UTC
Impact: • This maintenance will lead to approximately 5 Minutes of downtime within the 4-hour maintenance window. • New desktop launches would be affected during this period, while already existing desktop sessions should remain unaffected. • The provisioning of new pool VMs and expansion of existing pools may experience failures during the maintenance window.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.