Horizon Cloud Service Next Gen: Data Center Maintenance is now complete.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Posted Sep 15, 2025 - 07:22 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2025 - 04:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2025 - 06:05 UTC
Scheduled
Horizon Cloud Service Next-Gen will perform scheduled maintenance on the United States VM Hub during the window listed below.
The West US 2 Regional Clusters will remove support for the Legacy Certificate Authority, as outlined in the previously communicated KB article: https://kb.omnissa.com/s/article/6000824
Maintenance Window: • Start: Monday, September 15, 2025, 04:30 UTC • End: Monday, September 15, 2025, 12:30 UTC
Impact: • Virtual Machines (VMs) which couldn’t be updated to new Omnissa Certificate Authority, will lose connectivity to the Horizon Cloud next-gen control plane after this update. This means: • Users won’t be able to access the affected Virtual Machines (VMs) and applications. • The VMs will show as "Unavailable" in the Horizon Universal Console. • For instructions on how to recover and repair these affected VMs, please refer to following KB article: Repairing and Recovering Single-session and Multi-session Pool VMs That Lose Connectivity to Horizon Cloud Next-Gen after Root CA Update (6000944) (https://kb.omnissa.com/s/article/6000944). • VMs which were already rotated to new Omnissa Certificate Authority, are generally unaffected except Next-Gen desktop or application users may experience intermittent access issues. However, retry should succeed.