Horizon Cloud Service next-gen: Increased Request Error Rate - All Region

Incident Report for Omnissa Workspace ONE

Monitoring

Horizon Cloud Service Next-Gen has completed actions to remediate the issues and confirm that the services are available.

Operations teams are continuing to monitor the availability of the service to ensure the recovery is complete.
Posted Jul 23, 2026 - 18:44 UTC

Update

Horizon Cloud Service Next-Gen continues to experience an issue affecting desktop and application launches, as well as logins to the Universal Console (Admin Console). Active user sessions and existing connections remain unaffected.

The engineering team has identified that backend databases supporting these systems are impacted by a Microsoft Azure outage. The initial mitigation steps are taking longer than anticipated, and the team is now implementing alternate mitigation methods to restore normal service. We will provide the next update within 1 hour or sooner if new information becomes available.
Posted Jul 23, 2026 - 17:47 UTC

Identified

Horizon Cloud Service Next-Gen continues to experience an issue affecting desktop and application launches, as well as logins to the Universal Console (Admin Console). Active user sessions and existing connections remain unaffected.

The engineering team has identified that backend databases supporting these systems are impacted by a Microsoft Azure outage and is actively implementing mitigation measures to restore normal service. We will share further updates as soon as new information becomes available.
Posted Jul 23, 2026 - 16:22 UTC

Update

Horizon Cloud Service Next-Gen continues to experience an issue affecting desktop and application launches, as well as logins to the Universal Console (Admin Console). Active user sessions and existing connections remain unaffected.

The engineering team has identified a backend database issue as the root cause and is actively working toward a resolution. We will share further updates as soon as new information becomes available.

Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Posted Jul 23, 2026 - 15:45 UTC

Investigating

Horizon Cloud Service next-gen is investigating increased error rates for requests made to the service. There may be limited or no service impact at this time.

Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Posted Jul 23, 2026 - 15:14 UTC
This incident affects: Horizon Cloud Service Next-Gen (Universal Console - US, Universal Console - Ireland, Universal Console - Japan, Horizon Portal - Broker - US, Horizon Portal - Broker - Ireland, Horizon Portal - Broker - Japan).