Horizon Cloud Service Next-Gen Data Center Maintenance is now complete.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Posted Jul 26, 2025 - 11:11 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2025 - 10:30 UTC
Scheduled
The Horizon Cloud Service Next-Gen data center in the Japan region is scheduled for an infrastructure upgrade during the maintenance window below:
Maintenance Window: • Start: Saturday, July 26, 2025, 10:30 UTC • End: Saturday, July 26, 2025, 14:30 UTC
Impact: • No impact to user sessions or connections. • No impact to Azure and AWS edges. • For Horizon 8 edges, cloud-managed operations such as image import, clone, and publish may encounter intermittent failures during the maintenance. However, retry attempts should succeed.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Additional Information and Support: Please visit Service Support Website at Customer Connect (https://customerconnect.omnissa.com/home) to submit a case through Customer Connect. For information on contacting service support, see How to file a Support Request in Customer Connect (https://kb.omnissa.com/s/article/2006985).
Thanks for your patience.
Additional Information: Omnissa Horizon Cloud Service Team will provide additional updates on our Unified Status page (http://status.workspaceone.com) until the maintenance activity is complete.
Posted Jul 17, 2025 - 07:23 UTC
This scheduled maintenance affected: Horizon Cloud Service Next-Gen (Horizon Cloud Service Next-Gen - Japan).